
FEMAP NeiNastran  
Learning Series 
Tutorial Name: Offset Contact Surfaces. 
Tutorial Time: 15 to 30 minutes. 
Recommended Experience: Minimal to Moderate 
 
 
Scope: This tutorial will provide the user with an understanding of the effects of using 
offset contact surfaces in non-linear static FEA models. Offset contact surfaces is a 
specific tool with in the NeiNastran Solver that allows the user to alter the initial 
penetration of two contact surfaces. This is a powerful non-linear tool that can be used to 
model interference fits, bolt preload, and many more real world situations. In this tutorial 
we will be examining the pressure generated when  a steel insert is pressed into an 
aluminum housing with an 0.005 inch interference fit. The parasolid model used for this 
tutorial is "PRESSFIT.X_T", this model was crated using Metric units. In this parasolid 
there is zero interference modeled between the steel insert and aluminum housing. The 
steel insert has an outer diameter of 2.70 inches and the aluminum housing has a inner 
diameter of 2.70 inches. Therefore offset contact surface must be utilized to generate the 
0.005 inch interference. 
 
 
Input Model: PRESSFIT.X_T 
 
Units: English 
 
Preprocessor: FEMAP 10.1.1 
 
Solver: NeiNastran 10.0.1.763 
 
Postprocessor: FEMAP 10.1.1 
 
NeiNastran Solver Commands: NCONTACTGEOMITER 
 
 
MODELING 
 
To start this example we will begin by importing the model "PRESSFIT.X_T". From the 
FEMAP Main Menu select File-> Import-> Geometry...  
 
 



 
 
Locate the file "PRESSFIT.X_T" and select open. 
 
This will bring up the "Solid Model Read Options" box. 
 

 
 

1. I the "Geometry Scale Factor" Input line enter "1". (This sets the scaling option 
for importing models, since this model was created in Metric units and the 
FEMAP model will be created inches, the Scaling Factor should be set to 39.37. )  

2. Select "OK". 
 
This will bring up the "Femap" input box. 
 



 
1. Select "No" from the two options. (Selecting "Yes" will change the scale factor to 

match what is in the part file. Selecting "No" will modify the scale of the model to 
match the Geometry scale factor input in the "Solid Model Read Options" input 
box.) 

 

 
 
 
The Parasolid model that will be used for preprocessing the FEA models has been 
successfully imported. You will notice that the steel insert and aluminum housing are 



both 1/8 symmetry models. This was done in order to simplify the model and reduce the 
solving times. 

 
MESHING 
 
Now that the 3-D has been imported we must prepare the mesh for the FEA model.  
 
From the FEMAP Main Menu select Mesh-> Mesh Control -> Size on Solid... 
 

 
 
This will bring up the "Entity Selection" input box. 

 
1. Using the mouse select the outer ring that is the aluminum housing. 
2. Click "OK" 

 
This will bring up the "Automatic Mesh Sizing" input box.  



 
1. Under the "Size For" section select the radio button "Hex Meshing". 
2. In the "Basic Curve Sizing" section enter 0.05 in the "Element Size" input line. 
3. Select "OK" 
 

From the FEMAP Tools Menu select View Style-> Mesh Size 
 

 
 
If the view geometry toggle is on this will generate the element spacing on the exterior 
surfaces of the solid models to be displayed.  



 

 
 
From the FEMAP Main Menu select Mesh-> Mesh Control -> Size on Solid... 
 

 
 
This will bring up the "Entity Selection" input box. 



 
1. Using the mouse select the outer ring that is the aluminum housing. 
2. Click "OK" 

 
This will bring up the "Automatic Mesh Sizing" input box.  

 
1. Under the "Size For" section select the radio button "Hex Meshing". 
2. In the "Basic Curve Sizing" section enter 0.05 in the "Element Size" input line. 
3. Select "OK" 

 



 
 

The size for the mesh has been defined, however the element spacing of the inner 
diameter of the aluminum housing and outer diameter of the steel insert do not match. 
This will produce invalid results, and it must be corrected. 
 
From the FEMAP Main Menu select Mesh-> Mesh Control -> Size Along Curve... 
 

 

 



 
 

This will bring up the "Entity Selection" input box.  

 
1. Using the mouse select all of the curves that compose the outer diameter and 

inner diameter of the aluminum housing and steel insert. The should be eight 
curves in total. 

2. Click "OK" 
 
 
This will bring up the "Mesh Size Along Curves" input box.  
 

 
1. In the Mesh Size input area enter 50 in the Number of Elements input line. 
2. Select "OK" 
 
 
 



 
 

The size for the mesh has been successfully defined 
 
From the FEMAP Main Menu select Mesh-> Geometry -> HexMesh Solid... 

 

 
 
 

This will bring up the "Entity Selection" input box.  



 
1. Using the mouse select the aluminum housing. 
2. Click "OK" 

 
This will bring up the "Define Materials" input box.  

 
Select "Load..." at the bottom of the input box. 
 
This will bring up the "Select From Library" input box.  



 
1. Using the mouse select "6061-T651 Al Plate". 
2. Click "OK" 

 
This will bring up the "Define Materials" input box, with the material properties for 
6061-T651 Plate entered into the appropriate input fields. 
 



 
1. Click "OK" 

 
This will bring up the "Hex Mesh Solid" input box.  

 
1. Under the "Mesh Generation" section check the "Midside Nodes" check box. 



2. Under the "Mesh Generation" section uncheck the "Merge Nodes on Slaved 
Surfaces" check box. 

3. Select "OK" 
 

 
 
If the view elements toggle is on this will generate the element spacing on the exterior 
surfaces of the solid models to be displayed.  
 
From the FEMAP Main Menu select Mesh-> Geometry -> HexMesh Solids... 
 

 



 
 
 

This will bring up the "Entity Selection" input box.  

 
1. Using the mouse select the steel insert. 
2. Click "OK" 

 
Since a material properties has already been defined this will bring up the "Hex Mesh 
Solids" input box.  



 
1. Select the "Element Property" button. (This button is highlighted above with a red 

circle.) 
 
This will bring up the "Define Property" input box.  
 

 
1. Select the "Material Property" button. (This button is highlighted above with a 

blue circle.) 
 
This will bring up the "Material Property" input box.  



 
Select "Load..." at the bottom of the input box. 
 
This will bring up the "Select From Library" input box.  

 



1. Using the mouse select "AISI 4340 Steel". 
2. Click "OK" 

 
This will bring up the "Define Materials" input box, with the material properties for AISI 
4340 Steel entered into the appropriate input fields. 

 
1. Click "OK" 

 
This will bring up the "Define Properties" input box.  
 

  
1. Click "OK" 

 
This will bring up the "Define Properties" input box.  



 
1. Under the "Mesh Generation" section check the "Midside Nodes" check box. 
2. Under the "Mesh Generation" section uncheck the "Merge Nodes on Slaved 

Surfaces" check box. 
3. Select "OK" 

 

 
 
If the view elements toggle is on this will generate the mesh on the exterior surfaces of 
the solid models to be displayed.  
 
 



 
 
 
 

Expand the Model tree under the Model branch by clicking on the "+". This will expand 
the branch to include additional branch named Elements, Materials, and Properties. Again 
expand the Model tree under the Materials branch by clicking on the "+". The model tree 
now shows the two materials defined earlier in the analysis. Placing the mouse over one 
of the materials and "right" clicking brings up an options menu, selecting "Color" allows 
the displayed color to be changed for each material. In this case the steel insert has been 
changed to red and the aluminum housing has been changed to blue. 
 
From the FEMAP Tools Menu select View Style Options-> Color With-> Material 
Colors. 
 
 
 



 
 
If the view elements toggle is on this will generate the mesh on the exterior surfaces of 
the solid models to be displayed in the specified colors chosen accordance to the material 
properties.  
 

 
 
 



APPLYING CONNECTIONS 
 
Expand the Model tree under the Connections branch by clicking on the "+" in front of 
the first load set that was just created.  
Second mouse click on the "Connection" branch in the model tree then select 
"Automatic" from the pop up the menu. 
 

 
 
This will bring up the "Entity Selection" input box. 

 
1. Using the mouse select both the aluminum housing and the steel insert, that were 

imported during the modeling process. (Note "Select All" automatically selects 
every solid in the model environment and can also be used select both rings.) 



2. Click "OK" 
 
This will bring up the "Auto Detection Options for Connections" input box. 

 
1. Leaving the default setting Click "OK" 

 

 



The connection between the aluminum housing and steel insert has now been created. 
Expand the Model tree under the Connection branch by clicking on the "+". This will 
expand the branch to include additional branches named Properties, Regions, and 
Connectors. Again expand the Model tree under the Properties branch by clicking on the 
"+". The model tree now shows the one connection property defined by the Automatic 
Contact Detection  performed earlier in the analysis. Placing the mouse over this property  
and "right" clicking brings up an options menu, select "Edit". 
 
 

 
 

This will bring up the "Define Connection Property" input box. 



 
 

1. In "Penetration Type" pull down box under the "Penetration" input section, use 
the pull down box to select "Symmetric contact". (This defines the type of contact 
used for the analysis.) 

2. Under the "Penetration" input box, under "Max Activation Dist" uncheck 
"Automatic". If "Automatic" is unchecked move to step 3. 

3. Under the "Penetration" input box in the "Max Activation Dist" input line enter a 
value of 0.050. (This value controls the number of contact surface elements 
created. In this case by specifying 0.050, FEMAP will create master element at 
the surface of each element face of the steel insert with corresponding slave 
elements created on the aluminum housing at a distance of 0.050 inches. Since 
our mesh size for this models was 0.05, this was chosen as the starting point for 
the number of slave elements created.) 

4. Under the "Penetration" input box in the "Penetration Surface Offset" input line 
enter a value of 0.0025. (This value will offset each contact surface by a distance 
of 0.0025, since we have two surface each offset 0.0025 inches, this mimics the 
0.005 inch interference. With no change to the parasolid model or element mesh 
the interference between the aluminum housing and steel insert can be quickly 
altered, making optimization for pressure and stress extremely simple. 
Demonstrating the power and simplicity of this tool.)   

5. Click "OK" 
 
The connection for the aluminum housing and steel insert have been created and 
optimized for this FEA model. 

 



APPLYING LOADS 
 
Expand the Model tree under the Model branch by clicking on the "+" symbol. This will 
expand the branch to include additional branches named Elements, Materials, Properties, 
Layups, Loads, Constraints, Functions, and Data Surfaces. Second mouse click on the 
"Loads" branch in the model tree then select "New" from the pop up the menu. 
 

 
 

This will bring up the "New Load Set" input box. 
 

 
1. Enter "Gravity" into the Title input line. 
2. Click "OK" 

 
 
 
 



 
Expand the Model tree under the Model branch by clicking on the "+" symbol. This will 
expand the branch to include additional branches named Elements, Materials, Properties, 
Layups, Loads, Constraints, Functions, and Data Surfaces.  Again expand the Model tree 
under the Loads branch by clicking on the "+" symbol. This will expand the branch to 
include the new load set created. Expand the Model tree under the 1 ... Gravity branch by 
clicking on the "+" symbol. This will expand to include additional branches named Load 
Definitions, Body Loads, and Other Loads. Placing the mouse over the Body Load 
branch and "right" clicking brings up an options menu, select "Edit". 

 

 
 
 

This will bring up the "Create Body Loads" input box 



 
1. Under the Translation Accel / Gravity input section, check the Active 

checkbox. 
2. Under the Translation Accel / Gravity input section, enter 386.4 in the Ay 

input line. (This will apply a gravity load of 386.4 in/sec^2 this is the same as 
1 G, in the Y-axis to the FEA model.) 

3. Click "OK" 
 
The loads for the FEA model have now been defined. 
 

APPLYING CONSTRAINTS 
 
Expand the Model tree under the Model branch by clicking on the "+" symbol. This will 
expand the branch to include additional branches named Elements, Materials, Properties, 
Layups, Loads, Constraints, Functions, and Data Surfaces. Second mouse click on the 
"Constraints" branch in the model tree then select "New" from the pop up the menu. 

 



 
 

This will bring up the "New Constraint Set" input box. 
 

 
 

1. Enter "1/8Symmetry" into the Title input line. 
2. Click "OK" 

 
Expand the Model tree under the Model branch by clicking on the "+" symbol. This will 
expand the branch to include additional branches named Elements, Materials, Properties, 
Layups, Loads, Constraints, Functions, and Data Surfaces.  Again expand the Model tree 
under the Constraints branch by clicking on the "+" symbol. This will expand the branch 
to include the new Constraint set created. Expand the Model tree under the 1 ... 1/8 
Symmetry branch by clicking on the "+" symbol. This will expand to include additional 
branches named Constraint and Other Constraints. Placing the mouse over the Constraint 
Definitions branch and "right" clicking brings up an options menu, select "On Surface". 
 

 



 
 

This will bring up the "Entity Selection" input box. 
 

 



 
 

1. Select the six surfaces that make up the symmetry of the FEA model. (These six 
surfaces can be seen in the image above. The X-Axis symmetry can be seen 
highlighted in Green, the Y-Axis symmetry can be seen highlighted in Yellow, 
and the Z-Axis symmetry can be seen in Red. The Aluminum housing has three 
symmetrical surfaces and the Steel insert has three symmetrical surfaces, these six 
surfaces create the constraints for this FEA model.)  

2. Click the highlight button in the "Entity Selection" input box (The highlight 
button is circled in RED. Highlighting is not necessary however it is useful to 
ensure the proper surface have been selected as constraints.) 

3. Click "OK" 
 
This will bring up the "Create Constraints on Geometry" input box 



 
1. In the Advanced Types input section, select the "Surface" Radio button. (This will 

open up the additional options under the surface radio button. 
2. In the Advanced Types input section, under the Surface radio button select the 

"SLiding along Surface" Radio button. (This will automatically create Symmetry 
perpendicular to each of the surface selected earlier. 

3. Click "OK" 
 
 

The Constraints for the FEA model have now been defined. 
 
MANAGING ANALYSIS 
 
Placing the mouse over the Analysis branch in the model tree and "right" clicking brings 
up an options menu, select "Manage". 
 
 



 
 
 

This will bring up the "Analysis Set Manager" input box. 



 
 

1. Select "New" (Highlighted in the Red cicrle) 
 
This will bring up the "Analysis Set" input box. 

 
1. In the Title input field Enter "Pressfit". 
2. In the Analysis Program pull down menu select "31..NEINastran" 
3. In the Analysis Program pull down menu select "10..Nonlinear Static" 
4. Select "Next" 

 
This will bring up the "NASTRAN Executive and Solution Option" input box. 



 
 

1. Select "Next" 
 

This will bring up the "NASTRAN Executive and Solution Option" input box. 
 



 
1. Select "Next" 
 
This will bring up the "Master Request and Conditions" input box. 

 

 
1. Select "Next" 
 
This will bring up the "Nonlinear Control Options" input box. 



 
1. Under the Basic input section in the Increments or Time Steps input line Enter "5" 
2. Under the Output Control input section use the pull down box to select "3..ALL" 
3. Select "OK" 

 
 

This will again bring up the "Analysis Set Manager" input box, this time the analysis 
manager will be loaded with the values from the precious steps. 
 

 



 
1. Select "Analyze" 

 
This will bring up the "Save As" input box. 
 



 
1. Save the NEiNastran input file in a directory of your choosing with the name 

Pressfit.nas (Note whenever saving a NeiNastran input file always save the file 
with the extension ".nas") 

 
This will automatically bring up the NEiEditior, with the input file created from FEMAP. 
 



 
 

1. Select the Advanced Radio button in the Analysis Options menu. 
2. Select the "+" sign in front of "Nonlinear Solution Processor Parameters. 
3. Check to ensure the "NCONTACTGEOMITER" command is loaded with a "0" in 

the input field. If it is not enter the value 0. (NCONTACTGEOMITER is a 
command in the NEiSolver that determines the number of iteration before 
adjusting the position of slave nodes, since we have used offset contact surfaces in 
this model we want to offset these contact surface immediately, this is we loaded 
this input parameter as zero. 

 
The analysis is now ready to be solved.  
 
1. Press the "F5" button on the keyboard to begin the analysis. 



The analysis will solve for 3-4 minuets. After that the NEiEditor will display the 
following message. 

 
 
 
1. Select "Continue" 
2. Close the NEiEditor program. (Note depending on how your NEiEditor is 

configured once "Continue" is selected this may close the NEiEditor 
automatically. 

3. Return to FEMAP. 
 
 
Expand the Model tree under the Results branch by clicking on the "+" symbol. This will 
expand the branch to include additional branches , these branches are the solved results 
output from the NEiSolver. Placing the mouse over the branch labeled "Load = 1.0" and 
"right" clicking brings up an options menu, select "Contour". 
 
 
 
 



 
 

This will results have now be visually loaded to the model, and can be seen below. 



 
 
From the FEMAP Main Menu select View-> Select... 
 

 



This will bring up the "View Select" input box. 
 

 
 

1. Select "Deform" from the Deformed Style input box. 
2. Select "Contour" from the Contour Style input box. 
3. Click the "Deformed and Contour" Data button. 

 
This will bring up the "Select PostProcessing Data" Input box. 

 



1. In the Output set section of the window use the pull down menu to set the Output 
set to "10..INCR 5, LOAD=1.0"  

2. In the Ouput Vectors section of the windwo use the pull down menu to set the 
Deformation to "1.. TOTOAL TRANLASTION". 

3. In the Contour section of the windwo use the pull down menu to set the 
Deformation to "60033..SOLID MAX PRINCIPAL". 

4. Click "OK". 
 
 

This will again bring up the "View Select" input box. 

 
 

1. Click "OK" 
 



 
 
The model now shows the pure tension in the Aluminum housing.  The model is 
deformed using a scaling factor, in this instance deformation is greatly exaggerated. The 
amount this deformation is scaled can be adjusted. 
 
From the FEMAP Main Menu Select View-> Options....  
 
This will again bring up the "View Options" input box 
 



 
1. Under the Category input section select the radio button "PostProcessing" 
2. Under the Options input section select "Deformed Style". 
3. In the Scale % input line enter 0. (This will create a model that is deformed to 

the true deformation output by the NEiSolver.) 
 
 

 
 
 
 
 
 
 

 
 
 
 



 
 
 
 
 
 
 
 
 
From the FEMAP Main Menu select View-> Select... 
 

 
 
This will bring up the "View Select" input box again. 



 
 

1. Select "Deform" from the Deformed Style input box. 
2. Select "Contour" from the Contour Style input box. 
3. Click the "Deformed and Contour" Data button. 

 
This will bring up the "Select PostProcessing Data" Input box. 

 
 

1. In the Output set section of the window use the pull down menu to set the 
Output set to "10..INCR 5, LOAD=1.0"  

2. In the Ouput Vectors section of the windwo use the pull down menu to set the 
Deformation to "1.. TOTAL TRANLASTION". 

3. In the Contour section of the windwo use the pull down menu to set the 
Deformation to "60034..SOLID MIN PRINCIPAL". 



4. Click "OK". 
 

This will again bring up the "View Select" input box. 

 
 

1. Click "OK" 
 
 

 


